Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

× Ideal Store Locator Plugin (iStoreLocator) works with Google Maps API which allows your website visitors to easily locate stores/contacts on the map.

Product Page

Maximum number of locations to load per search

2 months 4 days ago #25598 by costelcovacescu
I have more locations, in more categories, source - tags.
If I set a maximum number of locations to load per search (for example 400), in the list of locations at the first load appear the first 400 locations within the initially set radius, regardless of the category.
After that, if I select just a category, the locations in that category appear only from the first 400 uploaded.
But in the initial range, I have more locations, which do not appear due to those in another categories initially loaded.
Is it possible that when selecting a category, to appear the first 400 of that category?
Thank you!
Costel Covacescu

Please Log in or Create an account to join the conversation.

2 months 4 days ago #25599 by support
Dear costelcovacescu,

I'm not sure exactly what you mean. Are you using Categories as Filters in iStoreLocator?
Every time a search or filter changes iStoreLocator sends a request to the server to retrieve the results, therefore the map is "populated" again with the pins (locations) for the current results.

You can choose iStoreLocator to load only one specific category using the following shortcode syntax:
{istorelocator height=|600| source=|com_contactenhanced| category=|ID|}

Just change the ID for your Contact Enhanced » Category ID.

You can also choose to load more categories at the same time, just add multiple category IDs separated by commas:
{istorelocator height=|600| source=|com_contactenhanced| category=|1,2,3,4|}

Best regards,

Please Log in or Create an account to join the conversation.

2 months 4 days ago #25600 by costelcovacescu
I have meant that for me every time a filter changes, iStoreLocator does not send a request to the server.
I have sent you some attachements
I am using tags as source.
Attachments:

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago #25603 by costelcovacescu
An advice, please.
Thank you!

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago #25604 by support
Dear costelcovacescu,

That's a very strange behavior.

Can you please provide a direct link, so I can take a closer look?

Best regards,

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago #25605 by costelcovacescu
Sure.
www.doctorpediatru.ro/
The problem appears when i select a category (filter).
For the moment, because of this issue, I set maximum number of locations - all, but a max distance - short (2 km), so a user in this area does not have many locations, so that the loading time is not too long.
Thank you!

Please Log in or Create an account to join the conversation.

1 month 4 weeks ago #25606 by support
Thank you for the link.

I've been checking and it seems the apparent problem is because you have a different view area (radius/range) for each screenshot.
In this case, the number of pins for a selected area might be different because of the different radius.

Have a blessed weekend.

Best regards,

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago #25608 by costelcovacescu
I have the same radius, the maximum number of locations to load per search is different, and the problem appears when I change the limit. May be an issue of the database.
Have a nice weekend, too!

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago #25610 by support
Dear costelcovacescu,

I'm not sure what's the issue here.

If you have a different limit the search results will be different. If you want to display all locations I recommend setting Result Limit to All in the plugin options under the Search tab.

In order to improve speed, if you have thousands of locations, you may need to change the Max Distance List (range select list) to something like 5,10,25,50,100,200 and the Selected Max Distance to 10 or 25.

Best regards,

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback