Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

Translation with ini-file and problems with IE8

8 years 10 months ago #8911 by Ricci
Hi Douglas,

It seems, that translations in the file joomla/language/en-GB/en-GB.mod_ajax_contact.ini is not covering all fields. I want to translate the error message (if a user leaves a required field empty), but the message is still in English. On the other hand, the succes message works fine. Please see at www.ck-runners.at/aktivitaeten/silvesterlauf .

The second (and more importent) issue is, that the validation don't work with IE8. When leaving a required field empty (which should produce an error message), the result is a success message!

For better understanding i attached screenshots showing the modul in the frontend (IE8 and FF 3.6).

Would be great, if you can help me.






Regards
Richard
Attachments:

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8913 by douglas
Dear Richard,

The language file is joomla/language/en-GB/en-GB.mod_ajax_recommend.ini instead of joomla/language/en-GB/en-GB.mod_ajax_contact.ini

I've accessed your website and I could not find the Ajax Recommend form. Can you please post a direct link to a page containing the form?

Best regards,

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8916 by Ricci
Thanks for your quick response!
Sorry, i had mistyped the filename, naturally i used en-GB.mod_ajax_recommend.ini

The link above should show the form now.

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8919 by douglas
Dear Richard,

I see youare using Joomla 1.5,

Can you please disable the MooTools Upgrade plugin for testing resons?

Clear the caches and reload the page. If it works it is a MooTools related error and I'll work on a fix.

Best regards,

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8922 by Ricci
Hi,
i've done your suggestion. The problem with IE8 is disappearing :) , the validation seems working correct.
The translation is still in English, i have attached the ini-file for your information.

I detected another issue: the Security question is not shown, although the setting is "Allways"

Regards
Richard

This message has an attachment file.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8927 by douglas
Dear Richard,

Did you translate it to your language?
Be sure you've uploaded it to teh right directory, some people get confused.
The RIGHT directory: [Path to Joomla]/language/
The WRONG directory: [Path to Joomla]/modules/mod_ajax_recommend/language/

Is the Captcha plugin enabled and configured properly?

Best regards,

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8928 by Ricci
Dear Douglas,

The path must be the right one, because the success-message and all the other translations are working fine. I guess, i'm wrong with the position within the ini-file. If you try at my page, you can see, that the error-message contains a little mistyping-error ("There are some invalid fields, please check feilds in red"). I can't find this text or a proper variable name in the ini-File anywhere in order to replace them with german text. Could you check the previously attached file?

Regarding Captcha: Ups, plugin was not activated, sorry for the needless request :blush:

Richard

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8929 by douglas
Dear Richard,

Actually when Joomla loads the module it will try to load the files in [Path to Joomla]/modules/mod_ajax_recommend/language/ if it does not find in [Path to Joomla]/language/, however the ajax part will not look for the language files in that directory.

That's why you only get not translated strings when the form is submitted.
The error message should be this one:
THERE WERE SOME ERRORS, PLEASE VERIFY THE FIELDS IN RED=There were some errors, please verify the fields in red

Best regards,

Please Log in or Create an account to join the conversation.

8 years 10 months ago #8930 by Ricci
This is confusing :( . I translated also the text in [Path to Joomla]/modules/mod_ajax_recommend/language/en-GB/ - no success. Please be aware of the spelling in the error-massage ("feilds" instead of "fields"). I can't find this string in the any of the both language-files.
I'm wondering, why it works with the green Thank you-message?

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback